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 Scenario 4:  Adding Missing Punctuations 

 Scenario 5:  Extracting a Subset of Records Based on Call Number Ranges  
 

 
 

 

In the Basic Concepts section we’ll be using 
RegExr, a regex online testing tool available at 
https://regexr.com/ 
 
In addition to the default global flag, select the 
multiline flag. In most cases the global mode, 
which ensures that the regex tool does not stop 
after the first match, would suffice. But when 
using special characters that designate 
beginning/end of line, the regex tool needs to be 
in multiline mode. 
 
Note that MarcEdit recognizes beginning/end of 
line characters by default. 
 

https://regexr.com/


 
 

Regex Rules!    Page 2 

Regular Expressions (regex): 

Introduction and Basic Concepts 
 

GENERAL INFORMATION 

 
 

 

 

 

 

 

 

 

 

 

 

 

 
 

 

 
 

 

 

Regex Resources  
 Getting started with regex (Terry Reese) 

o Power Point: https://www.slideshare.net/reese_terry/getting-started-with-regular-expressions-
in-marcedit 

o YouTube video: https://www.youtube.com/watch?v=7YXvS4xBEfw&feature=youtu.be 

 RegexOne (interactive regex tutorial): https:regexone.com 

 Microsoft.net regex site (quick reference and other tools): https://docs.microsoft.com/en-
us/dotnet/standard/base-types/regular-expression-language-quick-reference 

 

 
Online Regex Testing Tools 
 RegExr:  https://regexr.com/ 

 Regex101:  https://regex101.com/ 

 RegEx Pal:  https://www.regexpal.com/ 

 

  

 
What is Regex and Why Should We Use It? 

 
Normally, when we search for a text string, we look for exact matches. For example, when 

we search for “cat”, we want the first character to be a “c”, the second character to be an 

“a”, and the third character to be a “t”. But what if we just want the first character to be a 

capital letter, any capital? We can do 26 separate searches (Aat, Bat, etc.) or we can use a 

search term to capture a number of different characters.   

 

With regex we are able to look for a search PATTERN when a regular search cannot 

accomplish what we are trying to do.   

 

Characters in regex can be treated either as regular characters such as a, b, C, D, 1, 2 and 

are thus called “literals”, or have special function. Characters with special function in regex 

are called METACHARACTERS or SPECIAL CHARACTERS.    
 
 

https://www.slideshare.net/reese_terry/getting-started-with-regular-expressions-in-marcedit
https://www.slideshare.net/reese_terry/getting-started-with-regular-expressions-in-marcedit
https://www.youtube.com/watch?v=7YXvS4xBEfw&feature=youtu.be
https://regexone.com/
https://docs.microsoft.com/en-us/dotnet/standard/base-types/regular-expression-language-quick-reference
https://docs.microsoft.com/en-us/dotnet/standard/base-types/regular-expression-language-quick-reference
https://regexr.com/
https://regex101.com/
https://www.regexpal.com/
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BASIC CONCEPTS 

 

Anchors & Escapes 

^ (caret)   Matches beginning-of-line position 
$ (dollar sign)  Matches end-of-line position 
\ (backslash)  1.  Has a special function when coupled with a specific letter (e.g., \n matches new 

line) 

2.  Specifies that a metacharacter should be treated as a literal. In regex this is called 

“escaping” a metacharacter   

 

^ (caret)           $ (dollar sign) 

 

 

Example #1 
 
^app matches only 
the “app” in apple 
and application   
 
IMPORTANT:  In 
some contexts, the 
caret has a different 
function. See 
section on 
Character Classes. 

 

Example #2 
 
le$ matches the two 
last letters in apple and 
grapple 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Useful Tips 
 

The dollar sign ($) is useful for finding and adding character(s) or strings at end of fields 
and subfields, e.g., missing punctuation or additional subfields or text.  
 
The dollar sign combined with the caret (^) is useful for establishing the boundaries of 
the string, e.g., ^abc$ matches the entire “abc” string and nothing else.  
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\ (backslash) 
When coupled with a specific letter the backslash has a special function (e.g., \d matches any digit), but 
when preceding a metacharacter, it does the opposite and “escapes” the metacharacter so it can be treated 
as a literal (e.g., since the question mark is a metacharacter, we need to escape it with a backslash – \? – if 
we want to use it as a literal) 
 
 
 
 
 
 
 

 

 

 
 
 
 
 
 
 
 
 
 

 

 

  

Metacharacters such as ^ $ \  | . * + ? { } [ ] ( ) need to be 
ESCAPED with a backslash (\) to match literal characters  
 

Exercise 1 
 

apple 
popsicles 
grapple 
lesson 
application 

Write an expression that matches 
only the words that end with ple 

 

 
 

 
 

 

Exercise 2 
 

How would you express $z in the following field?  
How would you express $u?  

 
856  40$zOnline Resource$uhttp://www.heinonline.org 
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Character Classes 
[abc]  Matches any one of the enclosed characters. Case sensitive, but order does not matter 
[^abc] Matches any character NOT enclosed in the square brackets. In this example every character 

is matched EXCEPT for “a”, “b”, or “c”. Also case sensitive, but again, order does not matter 
[ - ]   A range of characters, e.g., [a-z], [A-Z], [0-9] 
. (period)  Matches any single character except line break 
\w   Matches any alphanumeric character as well as underscore; same as [a-zA-Z0-9_] 
\W   Matches any character that is not alphanumeric or underscore; same as [^a-zA-Z0-9_] 
\s              Matches whitespace characters such as space, tab, and new line 
\S   Matches non-whitespace characters 
\d              Matches any digit; same as [0-9] 
\D              Matches any non-digit; same as [^0-9] 
 

              

 

 

 

 

              

 

  

 

 

 

Example #3 
 
This expression looks for 
matches on the literal 
letters “gr” followed by 
EITHER “a” or “e” 
 

 

Example #4 
 
Looks for matches on the 
literal letters “gr” followed 
by any letter that is NOT “a” 
or “e”. The caret (^) negates 
both the “a” and the “e” in 
the expression. 
  

Only ^ - \ [ ] need to be escaped inside a 

character class to match literal characters 
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Example #5 
 
Looks for matches on 
the literal letters “gr” 
followed by ONE of the 
vowels. Notice that the 
second “e” in “greet” 
and the second “o” in 
“groovy” are NOT 
matched. 
 

 

Example #6 
 
In this example, instead 
of listing all the possible 
vowels, we’re using a 
range of letters between 
“a” and “u.” The result is 
similar to #5, though 
unlike the previous 
example, it would also 
match any other 
character between “a” 
and “u” following “gr” 
(e.g., grp) 

 

 

 

 

 
 
 
 

Example #7 
 
What happens when 
we add the literal 
letter “y” to the end 
of this expression? 
“grey” and “gray” 
are matched, but 
“gravy” and 
“groovy” are not, 
even though they 
have the letter “y” at 
the end.  
 
QUESTION: Why is 
this? 
 

 

Example #8 
 
A period (.) matches 
any single character 
except line feed (\n). 
What happens when 
we put one in front 
of the “y?” The 
period is a 
placeholder for the 
single character “v” 
in “gravy,” so a 
match is identified. 
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Example #9 
 
Adding a second period 
allows a match on 
“groovy” because one 
period takes the place 
of the second letter “o” 
and the other period 
fills in for the letter ”v” 
 
QUESTION: What will 
happen if we add a 
third period (in front 
of the “y”) to the 
expression? 
 

 

Example #10 
 
\w represents any alpha-
numeric character, as 
well as the underscore 
character. This 
expression matches the 
literal letters “gr” 
followed by any alpha-
numeric character (\w), 
followed by any single 
character (.) 
 

 

 

 

 

Example #11 
 
\w is not case-sensitive. 
These matches would still be 
found if the letter “r” were 
capitalized in the text we’re 

matching against. 
 

 

Example #12 
 
\W matches any 
non-alphanumeric 
character 
 
The same result can 
be achieved using 
[^a-zA-Z0-9_] 

 

 

 

 

 

Example #13 
 
\d matches any digit. In 
this example, all the 
digits are matched, while 
the hyphens are not. 
 
The same result can be 
achieved using [0-9]  

 

Example #14 
 
\D matches characters that 
are NOT digits 
 
QUESTION: What is 
another way to obtain the 
same result? 
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Example #15 
 
\s matches a 
whitespace character 

 

Example #16 
 
\S matches non-
whitespace characters 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

Exercise 3 
 

 

Consider this sample text and regular 
expression. Can you think of a way to alter the 
expression to match the word “gravity” and 
nothing else? 

 

Exercise 4 
 

TMX-482 
GAL-931 
LTU-387 
JOYRIDE 
HTP 638 
IMGR8T 
GODOGGO 
WTX-495 
 

4.1  Here is a short list of license plate numbers. Write an 
expression that matches the properly formatted ones, i.e., 3 
letters, hyphen, 3 digits. 
 

 
TMX-482 
GAL-931 
LTU-387 
JOYRIDE 
HTP 638 
IMGR8T 
GODOGGO 
WTX-495 
 

 
4.2  Write an expression that matches the license plate number 
missing its hyphen. 

  



 
 

Regex Rules!    Page 9 

Quantifiers & Alternations 

 
* (asterisk)   Matches preceding expression zero or more times 
+ (plus)    Matches preceding expression one or more times 
? (question mark)  Matches preceding expression zero or one time 
{n}     Matches preceding expression exactly n times 
{n,}      Matches preceding expression n or more times 
{n,m}    Matches preceding expression between n and m times 
| (pipe)       Alternation/OR  

 

 

 

 

* (asterisk)          + (plus)          ? (question mark) 
 

 

Example #17 

 
The first .* matches 
any character before 
“leg” zero or more 
times 
 
The second .* 
matches any 
character after “leg” 
zero or more times 

 

Example #18 

 
The first .+ matches any 
character before “leg” 
one or more times 
 
The second .+ matches 
any character after “leg” 
one or more times 
 
Question: Why does this 
expression not match 
“legal” and “leg”? 
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Example #19 

 
^ matches the beginning 
of line 
 
.+ matches any 
characters after “leg” 
one or more times 

 

Example #20 

^ matches the beginning 
of line 
 
.? matches any character 
before and after “trial” 
zero or one times 
 
Question: Why does this 
expression not match 
“mistrial” and 
“industrial”? 

 

 

  

 

 
 
 
 
 
 

 

 

 

 

{n}       {n,}       {n,m}   
 

 

Example #21 
 
\d matches any digit 
 
{13} matches the preceding 
expression exactly thirteen 
times (this expression will 
match any 13-digit ISBN, as 
long as there are no spaces or 
hyphens between the digits) 
 
This expression can also be 
written as [0-9]{13} 

Example #22 

 
{n,} matches preceding expression n or 
more times 

 
.m{1,} matches am, umm, and hmmm   
.m{2,} matches umm and hmmm but 
NOT am 
.m{3,} matches hmmm but 
NOT am and umm 
.m{4,} matches none of the three words 

 

 

 

Exercise 5 
 

law 
laws 
bylaw 
lawyer 

5.1  Write an expression that matches all four words 
5.2  Write an expression that matches ONLY laws and lawyer  
5.3  Which word(s) does the expression .?law.+ NOT match?  
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Example #23 

 
{2,3} matches the preceding expression between two 
and three times, so when following the number “5”, it 
matches 55 and 555 
 
In addition to the above, this expression also requires 
the string to have first digit “4” and last digit “6” 
 
Question: Why does this expression not match “456” 
and “455556”? 

 

 
 

 
 
 

 

 
 
 
 

 

 

Exercise 6 
 

67805 
678805 
6788805 
67888805 

Which of these numbers are NOT matched by 
the expression 678{1,3}05? 
 

  
 

 

Exercise 7 
 

pizza 
piazza 
puzzle 
pizzeria 

7.1  Write an expression that matches puzzle and pizzeria only 
7.2  Which word(s) does the expression .*zz.{1,2} NOT match?  
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| (pipe) 

 

 

 

 

 

 

 
 

 

Example #24 
 
Matches entries that 
end with “le” OR “lo”  

 

Example #25 
 
Matches entries 
beginning with “app” 
OR “ban” 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 

 

 

 

Exercise 8 
 

=035  \\$a(OCoLC)ocm99988765 
=035  \\$a(OCoLC)ocn499887655 
=035  \\$aocm99988765 
=035  \\$aocn499887655 

Write an expression that matches 
OCLC numbers that begin with ocm 
OR ocn and do not have the (OCoLC) 
prefix 

 
 

Exercise 9 

Find at least three ways to express the 246 field up to the first 
subfield:   
 

=246[space][space][indicator][indicator]$ 
 

It is best practice to ALWAYS put alternations (OR) in parentheses to ensure the matching only 

of that part of the expression you want matched by the alternation. For example, think of the 

difference in search results for “white tables OR chairs” vs. “white (tables OR chairs)” 
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Grouping & Substitution 

Grouping (in Find):  In addition to using parentheses to restrict the application of certain functions to a specific 
part of the expression, they are also used for grouping substrings that can later be referenced in Replace (first 
group will be referenced as $1, second group as $2, etc.). These grouped substrings are often referred to as 
“subexpressions” or “capturing groups”.  

Substitution (in Replace):  Once a search pattern is specified in Find, a second expression is used in Replace to 
indicate what substitutions to make within the matched text. This is done by referencing the results of the search 
pattern and making the desired changes to that pattern. 

 

Example #26 

 

 
 

Group 1: ([md]onkeys): “m” or “d” followed by “onkeys” matches both “monkeys” and “donkeys”.  
This group is referenced in Replace as $1 
 
Group 2: (bananas|carrots): matches bananas OR carrots 
This group is referenced in Replace as $2 
 
Since we want to replace the word “love” with “eat”, we ignore the former and add the latter to the Replace 
string, with spaces on each side:  $1 eat $2  

 

Useful REPLACE Tips 
 

To add a literal MARC subfield in Replace, use $$ (two dollar signs) 
 
To add a literal number in Replace, put the number after the dollar sign in curly brackets. For example, to add “1” after 
the first referenced group ($1), express it as ${1}1$3. Without the curly brackets ($11$3), the system will think you 
want group eleven followed by group three. 
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\n (new line)  

The \n matches a new line, also known as line feed or line break. It is useful in MarcEdit when we want to 
insert a new field or split an existing field.  
 
Important: When writing an expression in MarcEdit that involves multiple lines, you need to check not only 
“Use Regular Expressions” but also “Use Multiline Evaluation”.  
 

Example #27 
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Brief introduction to MarcEdit 

 

GENERAL INFORMATION 

 What is MarcEdit? 

MarcEdit is a free universal library metadata tool, developed and owned by Terry Reese 

 System requirements for MarcEdit 7.x 

Windows 7+ (XP no longer supported) 

Windows .NET Framework 4.6+ 

 Installing MarcEdit 

Downloads available at http://marcedit.reeset.net/downloads 
 

To find out if you need the 32-bit or 64-bit download, click the Start button on your computer 

and click System (if it’s not listed, it should appear when you type ‘system’ in the search box). In 

the box that opens with information about the system, you should find your system type. 

 Help/Support 

MarcEdit Listserv (subscribe and search list archives): https://listserv.gmu.edu/cgi-bin/wa?A0=marcedit-l 

Post to MarcEdit Listserv: MARCEDIT-L@listserv.gmu.edu  

MarcEdit Tutorials on YouTube: https://www.youtube.com/user/tpreese/playlists 

Terry Reese reeset@gmail.com 

 

MARCEDIT MAIN WINDOW 

 
 

 

 

http://marcedit.reeset.net/downloads
https://listserv.gmu.edu/cgi-bin/wa?A0=marcedit-l
mailto:%20MARCEDIT-L@listserv.gmu.edu
https://www.youtube.com/user/tpreese/playlists
mailto:reeset@gmail.com
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OPENING A FILE OF MARC RECORDS 

There are various ways to open a file of .mrc records: 
 
1. Directly from file: Double-click on filename > Execute > Edit Records 

 
2. Via MARC Tools 

MarcEdit Main Window > MARC Tools icon > Select Operation: MarcBreaker  

Select Data to Process: Open…: select your binary (.mrc) file 

Save As…: select location and name mnemonic (.mrk) file  

Click Execute > Edit Records 
 

3. Via MarcEditor 

MarcEdit Main Window > MarcEditor icon 

Select File > Open  

At the bottom of the dialog box select MARC Files (*.mrc) Locate your file and click Open 

 

REGEX IN THE MARCEDITOR 

• File > Select Records for Edit 

• Edit > Find & Replace 

• Tools > Add/Delete Field 

• Tools > Copy Field Data 

• Tools > Edit Fields 

• Tools > Edit Subfield Data 

• Tools > Swap Fields 

• Tools > Regular Expression Store  

• Tools > Build New Field 

• Report > Custom Reports 

 

About MarcEdit File Formats 
 

MarcEdit saves MARC21 files in the following formats:  

 
*.mrc for records in raw MARC21 format (binary) 

*.mrk for records in human-friendly mnemonic format 

 

To convert records from .mrc to .mrk use MarcBreaker 

To convert records from .mrk to .mrc use MarcMaker  

 

MarcEdit can also read other file types such as Innovative Interfaces .out files, OCLC 

.dat files, vendor .001, .marc, and .bin files. To use these files in MarcEdit, change the 

file extension to .mrc via right-click > Rename or F2  
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Putting It All Together: 

Using Regular Expressions in MarcEdit 

 

 

 

 
 

 

 

 

 

BEST PRACTICES 

 

 Always, ALWAYS, ALWAYS keep an unedited copy of your original file 

 

 When testing a new expression, keep track of your various iterations of the expression in a separate text 

file so you don’t end up moving around in circles and repeating the same failed expressions  

 

 Always check each revision by viewing the targeted field BEFORE and AFTER via the Find function: 

o Edit > Find (Ctrl+F) 

o Enter field (e.g. =050) 

o Click Find All  

 

 Know how to use UNDO: 

o Option 1: Use the Windows-wide Ctrl+Z to undo your last edit; use Ctrl+Y to reverse your last 

Undo 

o Option 2: Select Edit > Undo (F2) 

o To undo your previous GLOBAL edit select Edit > Special Undo (Ctrl+Alt+F2) 

 

 When stuck, take advantage of the regex experts on the MarcEdit Listserv. They will not only help you 

construct your expression, but will often add a detailed explanation that can be very educational.   

 
 

  

“It is easy to write regular expressions to match what you want and 
expect.  It is much harder to write regular expressions that anticipate all 
possible scenarios so that they do not match what you do not want to 
match.”    

   Ben Forta 
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SCENARIO 1:  CHANGING ORDER OF SUBFIELDS 
 
Description: Some of the 856 fields in a file have $u followed $z, while others have $z followed by $u. We 
want all fields to follow the same pattern of $z followed by $u.  
 
Solution: In the MarcEditor select Edit > Replace (Ctrl+R). Check Use regular expressions 
 

 
Find: (=856  ..)(\$u.*)(\$z.*) 
 
Replace: $1$3$2 
(groups 2 & 3 are switched) 
 

 
Group 1: (=856  ..) 
 
Group 2: (\$u.*) 
 
Group 3: (\$z.*) 

 
(field 856[space x2][any character x2]) 
 
([dollar sign escaped][u][everything else]) 
 
([dollar sign escaped][z}[everything else]) 

 
$1 in Replace  
 
$2 in Replace 
 
$3 in Replace  
 

 
 
 
 
 
 

  

Exercise 10 
 

Some 040 fields have $e (Description Convention) appear before 

$b (Language of Cataloging). For example:  

 

=040  \\$aABC$erda$beng$cABC 

 

Write an expression to move $b before $e 
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SCENARIO 2:  ADDING MISSING SUBFIELD DELIMITERS/CODES 

 
Description: We have a file of MARC records with several different formats of 041 field. Some have two or 

three sets of three-letter language codes strung together in one $a, some have $b with two language codes 

strung together, and a few have $h appended at the end with no data. We want to delete $h and insert 

missing delimiters $a and $b between language codes. 

 
Solution: In the MarcEditor select Tools > Edit Subfield Data. Check Use regular expressions 

 

 
 

Step 1: Remove $h 
 
Field: 041 
Subfield: h 
Click Remove Text 
 
Note that this step does not require regex 

 

 
 
 
 

Step 2: Add $a between the first and second 
language codes in subfield "a" 
 
Field: 041 
Subfield: a 
Field Data: ([a-z]{4})([a-z]{3})  
Replace with: $1$$a$2 
Check Regular Expression 
 
Group 1: any four lowercase letters (the “a” in $a 
+ the first three-letter language code); referenced 
in Replace as $1  
Group 2: any three letters (the second three-letter 
language code); referenced in Replace as $2 
 
$$a in Replace inserts the missing $a between the 
two language codes. Click Replace Text 
 

 
Step 3: Add $a between the second and third language 
codes in subfield "a" 
 
Same as step 2, so just click Replace Text again. 
 
Note: If there are more than 3 language codes in $a, this 
step can be repeated multiple times until we get the 
message “0 modifications were made” 

 
 
 

 

Exercise 11 
 

Using Tools > Edit Subfield Data Add $b 

between the first and second language codes in 
subfield "b" 
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SCENARIO 3:  DELETING FIELDS BASED ON SPECIFIC CRITERIA 
 
Description: We received a file of MARC records that has a mixture of LC and non-LC subject headings. We 
wish to keep the former (LC 6xx with second indicator “0”) and delete the latter, but want to make sure the 
655 fields that do not have second indicator “0” are not deleted. 
 
Solution: In the MarcEditor select Tools > Add/Delete Field (F7). Check Use regular expressions 
 

 

=6               Beginning of 6xx field 
. (period)   Any single character  
[^5]            Any character other than “5” 
.{3}             Any three characters  
[^0]            Any character other than “0”  
 
Putting it together: =6.[^5].{3}[^0] 
 
Click Delete Field 
 
=650  \4$aOrganisation internationale.  
=651  \0$aSalem (Mass.) 
=655  \7$aStatutes and Codes.$2lcgft 
 
Only the first field fulfils all required 
criteria and will be deleted. The other 
two fields will remain untouched.  

 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 
  

Exercise 12 
 

We have a file of MARC records that includes multiple 856 fields with URLs for 

various domains, including llmc, heinonline, google, hathitrust, ebsco, and 

others. We want to keep only 856 with llmc OR heinonline and delete all other 

URLs.  

 

In the MarcEditor select Tools > Add/Delete Field 

 

Hint: Check the Delete Field Options section 
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SCENARIO 4:  ADDING MISSING PUNCTUATIONS 
 
Description: We received a file of MARC records with some 1xx fields missing the end period. We would like 
to add that period but ONLY if the field has no end punctuation such as period, hyphen, question mark, or 
closed parenthesis. Note that the expression below can be used for other fields such as 7xx and 6xx. 
 
Solution: In the MarcEditor select Tools > Edit Field Data (Ctrl+Shift+F3). Check Use regular expressions 
 

 

Find: (.*[^.\-?)])$ 
 
Remember that elements within square brackets are 
always interpreted as OR, and that only ^ - \ [ ] need 
be escaped within the square brackets. 
 
(        Start group (to be referenced in Replace as $1) 
 .*     Any character(s) 
[^      Open square brackets and add caret. The caret 
will negate everything within the square bracket:  
.        period (no need to escape), 
\-      or hyphen (escaped), 
?       or question mark (no need to escape), 
)        or closing parenthesis (no need to escape).  
]        Close square bracket 
)        Close group 
$       Match end of field 
 
Replace: $1. 
$1               Group 1 
. (period)   Added missing period (note that there is 
no “escaping” in Replace) 
 
Click Process 
 

  

 
 
 

  

  

Exercise 13 
 

We want to add a slash before 245$c, but only if it is missing. 

We tried this expression, but it’s not working. Can you identify 

the error(s)? 

Find: (=245.*[^/])(/$c) 

Replace: $1 \$2) 
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SCENARIO 5:  EXTRACTING A SUBSET OF RECORDS BASED ON CALL NUMBER RANGES 
 
Description: We would like to extract from a file of MARC records only those records for law reviews with 
call numbers between K1-K30.  
 
Solution: In the MarcEditor, follow these steps:  
 
File > Select Records for Edit 
 
❶ In Display Field enter 050$a 
 
❷ Click Import File 
 
❸ Enter your expression 
 
❹ Check Use regular expressions 
 
❺ Click the magnifying icon 
 
❻ Click Export Selected and rename your new file    
 
 

 
 

We are already displaying 050$a, so the 
expression can start directly with the call 
number range. 
 
^        Beginning of subfield 
K        Literal letter “K” 
(         Open parentheses for OR Subexpression 
[12]?  Zero or one instances of “1” OR “2”   
\d       Any digit 
|         OR 
30       Literal number “30” 
)          Close parentheses 
$         End of subfield “a” 
 
Putting it together: ^K([12]?\d|30)$  
 
The caret and dollar sign set important 
boundaries. Without them we could end up 
with numbers that have K in a place other than 
the beginning of the subfield, and call numbers 
with more than two digits.   
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THE PROCESS OF DEVELOPING THE ABOVE EXPRESSION 

 

^ = beginning of line 

K\d = K with any single digit (K1, K2, K3, etc.) 

OR 

K[12]\d = K with any two digits starting with “1” or “2” (K10, K11, K12, etc., or K20, K21, K22, etc.)   

OR 

K30 

$ = end of line 

 

Putting it together:   

^(K\d)|K[12]\d|K30)$ 

 

This expression works, but is longer than it needs to be. To simplify it, let’s take the “K”, which appears in 

every part of the expression, and use it only once outside the parentheses:  

^K(\d|[12]\d|30)$ 

 

To make it even more elegant, we can condense the expression for single and double digits using the 

question mark, which specifies that [12] will appear zero or one time. In other words, for single digit K 

numbers, the [12] will be ignored and only the \d (any digit) will be captured:   

^K([12]?\d|30)$ 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Exercise 14 

 
Description: We have a big file of records for vendor ebooks, but we want to 
load into our system only those titles with K and J call numbers. How can we 
extract these records?  
 
Using File > Select Records for Edit, write an expression that will identify all call 
numbers starting with “K” or “J” and will ignore all other call numbers. 
 

Try this exercise two ways: 
 
1.  In Display Field, enter 050$a 
2.  In Display field, enter 050 
 

How does each option affect your expression? 
 

 
 



Regular Expressions (regex) Commonly Used in MarcEdit 
 

Metacharacters:  . ^ $ | \ () * + ? {} [] -- These characters need to be escaped with a backslash (\) to match literal 

characters  

 

Anchors & Escapes 

^       (caret) Matches beginning-of-line position ^cat matches cat, catalog, but NOT scatter 

$       (dollar) Matches end-of-line position ght$ matches night, bright, but NOT lightning 

\       (backslash) 
Specifies the next character as either a 
special character or a literal 

\$a matches $a 

\n Matches new line 
.\n. matches 
This is first line; 
This is second line 

 

Character Classes 

Only ^ - \ ] need to be escaped inside a character class 

[abc] (Same as (a|b|c)) 
Character set. Matches any one of the 
enclosed characters.  

s[mc] matches small, scroll 

[^abc]     
Negative character set. Matches any 
character NOT enclosed 

c[^au]t matches cot but NOT cat or cut  

[ - ]   (hyphen with square 
brackets) 

A range of characters 
[a-zA-Z] matches any lowercase/uppercase 
letter  
[0-9] matches any digit 

.        (period) Matches any single character b.g matches big, bag, bug 

\w    Same as [a-zA-Z0-9] Matches any alphanumeric 1\w3 123 1a3 1B3 

\W   Same as [^a-zA-Z0-9] Matches any non-alphanumeric 1\W3 1%3, 1+3, 1$3 

\s     Same as [  ] Matches whitespace  
\.\s{2,3}[a-z] matches 
1.  xyz 
2.   xyz 

\S     Same as [^ ] Matches non-whitespace 
.*\.\S.* matches space missing between period 
and beginning of new sentence, e.g., abc.Xyz  

\d     Same as [0-9] Matches any digit 1\d3 matches 103, 113, 123, 133, etc.   

\D    Same as [^0-9] Matches any non-digit 1\D3 1a3, 1@3, 1B3 

 

Quantifiers & Alternations 

*       (asterisk) 

Matches preceding expression zero or more 
times 
(.*  matches any character zero or more 
times) 

il*e matches mile, pier, grille  
12*5 matches 15, 125, 12225, etc.  

+       (plus) 
Matches preceding expression one or more 
times 

ar+ matches are, arrow, carrier but NOT apple 
12+5 matches 123, 1225  

?       (question mark) 
Matches the preceding expression zero or 
one time 

mo?r matches more, ramrod but NOT mooring 
12?5 matches 15, 125 

{n} Matches preceding expression exactly n times 12{3}5 matches 12225 

{n,} 
Matches preceding expression n or more 
times  

12{3,}5 matches 12225, 122225, 1222225, 
12222225, etc. 

{n,m} 
Matches preceding expression between n and 
m times 

12{3,5}5 matches 12225, 122225, 1222225 

|       (pipe) Or cat|dog matches cat, dog 

 

Grouping (in Find) & Substitution (in Replace) 

(  )    (parentheses) 
 
$[group #] 

Group in Find. When matching a pattern 
within parentheses, we later use  
$1, $2, etc. in Replace to refer to the 
previously matched pattern 

Reverse Last Name, First Name 
 
Find: ([A-Z][a-z]+), ([A-Z][a-z]+) 
Replace: $2[space]$1  
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